Skip to:Bottom
|
Content

Supported Browsers & Platforms 

The appearance of Alexandria Library's web site interface and performance speed may vary based on the specific web browser and browser settings you are using. If you are using an outdated browser, you may have display and functionality issues. Below is a list of recommended browser versions. 

 

Browser

Supported Versions

Platforms

Download now Internet Explorer

10 and 11

Windows

Download now Google Chrome

Latest Version

Windows/Macintosh

Download now Mozilla Firefox

Latest Version

Windows/Macintosh

Download now Safari

6 and 7

Macintosh


Why do I need an up-to-date browser?

  • Security: Newer browsers protect you better against scams, viruses, trojans, phishing and other threats. They also fix security holes in your current browser.
  • Speed: Each new browser generation improves speed
  • Compatibility: Websites using new technology will be displayed more correctly.

 

Compatibility View in Microsoft Internet Explorer: 

  • If you are using Internet Explorer 8 or higher, make sure that you are NOT using Compatibility View .
  • To Turn Off Compatibility View
    1. See if the Compatibility View button  appears next to the Address bar.
    2. If the Compatibility View button  is blue, click it to disable Compatibility View.
    3. If you do not see the Compatibility View button , click Tools -> Compatibility View Settings. If lib.va.us is listed, it needs to be removed. Only "Download updated compatibility lists from Microsoft" should be checkmarked.
Go to:Top of Page